innQuest - Payment Processing Degradation – Incident details

Payment Processing Degradation

Resolved
Operational
Started 10 months agoLasted about 2 hours

Affected

US

Degraded performance from 4:05 PM to 6:06 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We performed service restarts at 1 PM EST, which appears to have resolved the credit card processing delays. Transactions should now be processing smoothly. Our teams will continue to monitor the situation closely. If you are continuing to see a high volume of time outs, please email our support team at support@inquest.com

  • Identified
    Identified

    We are still experiencing delays in our credit card processing response times which may at times cause transactions to time out. Our team is working diligently to identify the root cause of this issue and resolve it as swiftly as possible.

    Please ensure to review the portal for any possible duplicate charges as the transaction may have processed but the response back to roomMaster may have timed out.

  • Investigating
    Investigating

    We are aware of reported slowdowns with our RoomMaster Payments credit card processing. Some users may experience timeouts while processing credit card transactions.

    Our team is actively investigating this issue.