roommaster - Payment Processing Disruption – Incident details

Payment Processing Disruption

Resolved
Degraded performance
Started 19 days agoLasted about 1 hour

Affected

AMER

Degraded performance from 11:28 AM to 12:50 PM

rm Payments (T)

Degraded performance from 11:28 AM to 12:50 PM

Updates
  • Resolved
    Resolved

    Status: Resolved

    Customer note: Best practice: Whenever there is a processing issue, please take extra care before closing/settling your batch. Confirm your batch totals and review the payment portal to ensure there are no duplicate transactions.

  • Monitoring
    Monitoring

    Summary: The payment processing issue has been resolved and services should all be functioning normally within the next few minutes.


    Customer note: Best practice: Whenever there is a processing issue, please take extra care before closing/settling your batch. Confirm your batch totals and review the payment portal to ensure there are no duplicate transactions.

  • Identified
    Identified

    Current status: We have identified the issue affecting our payment application and are working toward a resolution.

  • Investigating
    Investigating

    Impact: Some customers may experience failed or delayed payment transactions.

    Current status: We are receiving reports of a payment processing disruption. Our engineering team is actively investigating to identify the cause and restore normal operation.

    Next update: We’ll provide an update as soon as more information is available.