roommaster - Connection Issue – Reservation Sync Delays – Incident details

Connection Issue – Reservation Sync Delays

Resolved
Operational
Started 3 days agoLasted about 4 hours

Affected

AMER

Degraded performance from 1:08 PM to 4:44 PM

Channel Manager / Booking Engine

Degraded performance from 1:08 PM to 4:44 PM

EMEA

Degraded performance from 1:08 PM to 4:44 PM

Channel Manager / Booking Engine

Degraded performance from 1:08 PM to 4:44 PM

APAC

Degraded performance from 1:08 PM to 4:44 PM

Channel Manager / Booking Engine

Degraded performance from 1:08 PM to 4:44 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Update: Expedia Connection Issue – Monitoring

    The connection issue with Expedia has been resolved.

    We are currently monitoring the system as reservations begin syncing back into roommaster. Due to the backlog created during the outage, it may take approximately 60–120 minutes for all reservations to be fully retrieved and reflected at the property level.

    We will continue to monitor progress and provide confirmation once all systems are operating normally.

    Thank you for your patience.

  • Update
    Update

    Update: Expedia Connection Issue

    We continue to work closely with the Expedia team to resolve the connection issue impacting reservation syncing.

    Our teams remain actively engaged, and progress is being made toward a resolution. We will provide further updates as soon as more information becomes available.

    Thank you for your continued patience.

  • Identified
    Identified

    We are currently experiencing a connection issue with Expedia that is impacting the retrieval of reservations into roommaster.

    Earlier today, Expedia experienced a system outage. While their services have since been restored, a follow-up connection issue is preventing some reservations from syncing properly.

    Impact:

    • New Expedia reservations may not be automatically imported into roommaster

    • All existing reservations remain intact and unaffected

    • No data has been lost

    Our team is actively working with Expedia to resolve the issue as quickly as possible. At this time, the issue appears to be related to a network-level restriction following their outage.

    Recommended Action:
    Please check Expedia Partner Central periodically for new reservations and manually enter any urgent bookings until the connection is fully restored.

    We apologize for the inconvenience and will provide updates as more information becomes available.