Affected
Degraded performance from 7:34 PM to 11:09 PM, Operational from 11:09 PM to 12:00 AM
Degraded performance from 7:34 PM to 11:09 PM, Operational from 11:09 PM to 12:00 AM
- MonitoringMonitoring
Resolved: roommaster Cloud performance has returned to normal, and the issue is fully resolved. Our Engineering team identified and corrected the underlying cause.
We sincerely apologize for the extended disruption today, especially during your check-in operations, and we thank you for your patience throughout the incident.
In a small number of cases, a room may still display an incorrect status, such as showing as occupied or “in use” when it is not. If this happens, please try the following steps in order:
Step 1 — Rebuild the Forecast
Go to Setup → Rebuild Forecast.
This resolves most lingering room-status issues.Step 2 — Reset the Room Status
If Step 1 does not resolve the issue, go into Housekeeping and change the affected room to a different status, then back again. For example, switch a Clean room to Dirty, then back to Clean.You may see the following warning:
Problem: Room status is occupied but no folio exists for room.
Solution: Press OK to fix room status.This message is expected. Please click OK, and the system will correct the room’s status automatically.
- UpdateUpdate
Update: Our Engineering team is currently implementing an additional fix to address the ongoing roommaster Cloud performance issue. We know this has taken longer than expected, and we appreciate your continued patience while this work is completed and monitored. We will provide another update once we have confirmed the impact of this latest fix.
- UpdateUpdate
Update: We recognize this issue has continued longer than expected, and we understand the impact this is having on your operations. Our Engineering team remains fully engaged and is continuing work to restore normal roommaster Cloud performance as quickly as possible. We appreciate your patience and will continue to share updates until the issue is resolved.
- UpdateUpdate
Update: Our Engineering team is still actively working to resolve the degraded roommaster Cloud performance. We appreciate your continued patience and will provide another update as soon as more information is available.
- UpdateUpdate
Update: Our Engineering team is currently implementing the fix for the degraded roommaster Cloud performance. We expect to see improved performance soon as the fix is applied and monitored. We understand the disruption this has caused, especially during guest check-in, and appreciate your continued patience. You do not need to submit a separate support ticket — we are actively tracking this issue and will continue to provide updates here.
- UpdateUpdate
Update: Our Engineering team is continuing to work on implementing the fix for the degraded roommaster Cloud performance. We know this is causing disruption, especially around guest check-in, and we appreciate your continued patience while the fix is completed and validated. You do not need to submit a separate support ticket — we are actively tracking the issue and will continue posting updates here. We will provide another update within 30 minutes.
- IdentifiedIdentified
Update: We have identified the cause of the performance issues affecting roommaster Cloud and our engineering team is actively working to implement a fix. We understand this is impacting guest check-in during a busy period, and we appreciate your patience. You do not need to submit a separate ticket — we are aware and working on it. We will post another update within 30 minutes.
- InvestigatingInvestigating
We are currently investigating reports of slow performance and errors affecting roommaster Cloud, particularly during guest check-in. Our Engineering team is actively working to identify and resolve the issue. You do not need to submit a separate support ticket - we are aware and tracking it here. We will provide an update within 30 minutes.
