roomMaster Cloud US Maintenance Window: Wednesday, April 15 4:00AM EDT Scheduled for April 15, 2026 at 8:00 AM – 9:13 AM
Affects
AMER
Under maintenance from 8:00 AM to 9:13 AM
roommaster (PMS)
Under maintenance from 8:00 AM to 9:13 AM
rm Payments (T)
Under maintenance from 8:00 AM to 9:13 AM
rm Payments (A)
Under maintenance from 8:00 AM to 9:13 AM
Channel Manager / Booking Engine
Under maintenance from 8:00 AM to 9:13 AM
Agora (API)
Under maintenance from 8:00 AM to 9:13 AM
Load more
Completed
April 15, 2026 at 9:13 AM Completed
April 15, 2026 at 9:13 AM Maintenance has completed successfully.
In progress
April 15, 2026 at 8:00 AM In progress
April 15, 2026 at 8:00 AM Maintenance is now in progress
Planned
April 15, 2026 at 8:00 AM Planned
April 15, 2026 at 8:00 AM Date: Wednesday, April 15 4:00AM EDT Time: 4:00AM - 5:30AM AST (America/St_Thomas) 4:00AM - 5:30AM EDT (America/New_York) 3:00AM - 4:30AM CDT (America/Chicago) 2:00AM - 3:30AM MDT (America/Denver) 1:00AM - 2:30AM PDT (America/Los_Angeles) 12:00AM - 1:30AM AKDT (America/Anchorage) 10:00PM - 11:30PM HST (Pacific/Honolulu - Tuesday, April 14) Duration: 90 Minutes We will be performing an update to your roomMaster Cloud application during a maintenance window early on Wednesday morning. During this period, all users must be logged out of the software and roomMaster Cloud will not be accessible. Please plan accordingly to remain out of the software for 90 minutes.