innQuest - roomMaster Payments Manual Card Entry issue – Incident details

roomMaster Payments Manual Card Entry issue

Resolved
Operational
Started 12 months agoLasted 11 minutes

Affected

US

Degraded performance from 3:42 AM to 3:53 AM, Operational from 3:53 AM to 3:54 AM

Updates
  • Resolved
    Resolved

    The Manual Credit card entry issue has been resolved.

  • Investigating
    Investigating

    We are aware of recent reports from some of our users regarding difficulties in manually adding credit cards to the

    roomMaster Cloud system. Our team is actively investigating this matter to identify the root cause and implement a swift resolution.

    Key Points:

    • Some users have experienced challenges when manually inputting credit card details.