innQuest - roomMaster Payments Processing Degradation – Incident details

roomMaster Payments Processing Degradation

Resolved
Operational
Started 9 months agoLasted about 7 hours

Affected

US

Degraded performance from 7:59 PM to 8:46 PM, Operational from 8:46 PM to 2:49 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Important Notice: Resolution of roomMaster Payments Issue 

      

    The recent issue with roomMaster Payments has been successfully resolved. 

      

    As a precaution, we recommend that you review your transaction history in the roomMaster Payments portal for any duplicate transactions that may have occurred during the disruption.  

  • Investigating
    Investigating
    We are currently investigating this incident.